Hyperliquid Mainnet: Hypercore Block Height stalled at 998,059,177

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted May 16, 2026 - 01:25 UTC

Monitoring

A fix has been implemented and block height is progressing at this time. Our engineers are working to backfill the gaps experienced throughout this incident. This issue will be marked as resolved following completion of the backfill.
Posted May 16, 2026 - 00:44 UTC

Investigating

Hyperliquid Mainnet is experiencing a stall at block height 998,059,177. This incident only affects Hypercore JSON-RPC queries. We will provide updates as soon as they become available.
Posted May 16, 2026 - 00:27 UTC
This incident affected: HyperLiquid (Hypercore - JSON-RPC API, Hypercore - Websockets API, Hypercore - Streams, Hypercore - Webhooks).