Robinhood Testnet Network Stalled at Block 63,024,491

Incident Report for Quicknode

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 20:56 UTC

Update

Block height is progressing across the node infrastructure. We will notify you once the nodes are in sync with the broader network.
Posted Jun 03, 2026 - 04:15 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 02, 2026 - 23:00 UTC

Investigating

Robinhood Testnet appears to have stalled at block 63,024,491 - Our team is investigating and we are working with the foundation to resolve the stall. We will update with more information once it is available.
Posted Jun 02, 2026 - 16:15 UTC
This incident affected: RobinHood (Robinhood Testnet - JSON RPC API, Robinhood Testnet - WebSocket API).