Stuck Network - Cosmos Mainnet stuck at block 25,283,300

Incident Report for QuickNode

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 03:23 UTC

Monitoring

Our nodes are progressing again, and we are monitoring performance while others are brought up.
Posted Apr 14, 2025 - 19:45 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 14, 2025 - 19:04 UTC

Update

The Cosmos Network is undergoing maintenance following getting stuck after a network upgrade
Posted Apr 14, 2025 - 16:18 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 14, 2025 - 15:06 UTC

Investigating

The Cosmos Mainnet appears to have stalled at block 25,283,300 - The QuickNode team is investigating and will update with more information once it is available.
Posted Apr 14, 2025 - 15:02 UTC
This incident affected: Cosmos (Cosmos Mainnet — REST API).